Notifications
Clear all

Error in Unity 2019.4.2  

(@gecko64)
Trusted Member Registered

We are upgrading our project from Unity 2019.4.0 to 2019.4.2, and getting this error on a couple Combu scripts:

Combu\Scripts\Profile.cs(10,25): error CS0535: 'Profile' does not implement interface member 'IUserProfile.gameId'

Similar error on User.cs

 

We're still on an older version of Combu3 (3.1.2) -- we can upgrade (if that'll fix it), but is there a quick fix without doing that?

thanks!

Dave

 

ReplyQuote
Topic starter Posted : 07/07/2020 4:09 pm
fry000 liked
(@skaredcreations)
Honorable Member Admin

I see that they added this new property to the IUserProfile interface in 2019.4.X, so edit /Combu/Scripts/Profile.cs and add the following code at top of the class (but don't use it in your code, since it's a feature only for Apple Game Center social platform):

protected string _gameId = "";

///
/// Gets the game player identifier
/// 
public string gameId { get { return _gameId; } }

 

It will be included in the next update.

FRANCESCO CROCETTI @ SKARED CREATIONS

ReplyQuote
Posted : 07/07/2020 4:29 pm
fry000 liked
(@gecko64)
Trusted Member Registered

Thanks much!

ReplyQuote
Topic starter Posted : 07/07/2020 5:18 pm
Share: